Welcome to Golden Software Support

Anyone noticed current version of surfer is slow to load

Comments

6 comments

  • Avatar
    Katie Yoder

    Hi David,

    Thank you for posting to the Surfer community.  No changes have been made to Surfer or the automation library that should affect the load time of the software.  Also, we have not had any other reports of this behavior from our users.  It is possible that one of the steps required to start the program is causing a delay on your system.  Do you see the same slow loading of Surfer when you start the program manually?  Could you please reproduce the increased loading time and then email the log file to support@goldensoftware.com?  The Surfer.log file can be found in C:\Users\<user name>\AppData\Roaming\Golden Software\Surfer 15\.


    Sincerely,
    Katie Yoder
    Technical Support

    0
    Comment actions Permalink
  • Avatar
    David

    Just for fun, I created this little program in Scripter....

    The HTML Clipboard

    Sub Main
    Set SurferApp = CreateObject("Surfer.Application")
    SurferApp.Visible = True
    End Sub

     

    When you execute this program, it takes about 22 seconds for Surfer to appear on the screen. I've tried this on 2 different computers, both running Windows 10, ver 1803 (Build 17134.285). Doesn't matter whether VB or Scripter, Surfer takes 22 seconds to load, whereas clicking the link manually takes 1 or 2 seconds. Why is automation so slow? It never used to be.

     

    0
    Comment actions Permalink
  • Avatar
    Katie Yoder

    Hi David,

    Thank you for your response.  I am not able to reproduce the 22 second initialization time when running this script.  Surfer opens in less than 1 second on my computer.  However, I did notice that the time to initialize using a script appears to decrease after registering the software through the command line.  Do you have multiple versions of Surfer installed on your computer?  If so, could you please unregister the previous versions and register the latest version by following the instructions below?

    1. Click the Start Menu, type CMD, and press ENTER to open the Command Line window.
    2. Enter the path to the previous version Surfer.exe file in quotes followed by /Unregister.  For example:
      "c:\program files\golden software\surfer 13\surfer.exe" /Unregister
    3. Press ENTER.
    4. Enter the path to the current version Surfer.exe file in quotes follow by /Register.  For example:
      "c:\program files\golden software\surfer 15\surfer.exe" /Register
    5. Press ENTER.

    Does Surfer 15 still take 22 seconds to initialize when running a script?

    Sincerely,
    Katie Yoder
    Technical Support

    0
    Comment actions Permalink
  • Avatar
    David

    My problems with Surfer being slow to start from automation appear to be related to  the version of Windows 10 that Microsoft just updated me to. I have version 1803 (Bd 17134.285). I resurrected two older machines and loaded Surfer 15 in trial mode and both machines loaded Surfer 15 in 1 or 2 seconds, whether using VB or Scripter. Those laptops were Windows 10 Home versions. One was version 10.0 Bd 10240 and the other was ver 1607Bd 14393.1770. So it looks like I have to pursue some kind of fix for version 1803. Both of these older laptops had Surfer 13 installed and both loaded Surfer 15 automatically from VB, even though the type library reference was to Surfer 13, so having multiple versions of Surfer on a machine does not appear to affect the speed to load Surfer 15.

    0
    Comment actions Permalink
  • Avatar
    David

    After running the Windows Update Troubleshooter and installing a couple of updates, I was able to get some improvement. VB will now load Surfer in about 10 seconds. Scripter still takes about 23 seconds. Now it's just a matter of getting the right update from Microsoft.

    0
    Comment actions Permalink
  • Avatar
    Katie Yoder

    Hi David,

    I'm glad you seem to have found the cause of the slow load times when Surfer is called via automation.  I am running Windows 7 with all of the latest updates.  If you do find that a specific update is contributing to this behavior.  I'm sure our developers and other customers would be interested to know.

    Sincerely,
    Katie Yoder
    Technical Support

    0
    Comment actions Permalink

Please sign in to leave a comment.