Welcome to Golden Software Support

how to reduce the Grapher file size?

Comments

5 comments

  • Avatar
    Sabrina Pearson

    Hi Igor,

    Glad I could help!

    Thanks!

    Sabrina

    0
    Comment actions Permalink
  • Avatar
    igorg
    Thank you, Sabrina! Your reply is efficient and in time as always! Regards, Igor
    0
    Comment actions Permalink
  • Avatar
    Sabrina Pearson

    Hi Igor,

    Normally when the file size increases, the reason is the embedded data. If you have saved the file to a GPJ file format, the data is embedded in the file. Changing the data could cause the large increase if the data layout (number of rows/columns) is greatly different than the original. Saving to a GRF will link to the data instead of embed it. This should make the file smaller.

    Another reason why the file size may be larger is due to inserting a company logo or other image. Grapher saves all images in non-compressed format, so this could increase the file size.

    A final reason why the image may be larger is due to the thumbnail that is created. It sounds like there are a great many data points. The thumbnail does have a point in the image for each of these. This can create a larger file. To turn off the thumbnail display, click the File | Options command. On the left side of the dialog, click General. On the right side, change the Save preview image as to Do not save preview image or Bitmap (low quality, smaller file). Click OK and save the file. The file size should be reduced. If this does not help, you can upload the Grapher file and data to https://goldensoftware.sharefile.com/r-rdf401abe93b4245b. I can then take a look.

    Thanks,

    Sabrina

    0
    Comment actions Permalink
  • Avatar
    igorg
    Dear Sabrina, The last option (Do not save preview image) allowed to reduce filesize to 7.5 mb (from 15 mb). Thank you for this. Another thing with this regard - it takes rather long time to make changes in the grf file - maybe this is because the large data files (xlsx) (the largest xls file I use is about 3900 rows)? thanks Igor
    0
    Comment actions Permalink
  • Avatar
    Sabrina Pearson

    Hi Igor,

    3900 rows is not very many rows. This shouldn't be causing a significant slowness, unless there are many plots in the graph. If there are many plots, each plot is updating with every change. There are a few things you can try:

    1. Turn off auto-track worksheet. To do this, click File | Options. Click on Plots on the left side of the dialog. On the right side, uncheck the Auto track worksheet option. Click OK. Grapher will no longer track the changes in the worksheet automatically. So, if the worksheet is changed in Grapher, you will need to save it and click the Graphs | Worksheet | Reload command to update the graph.
    2. Turn off auto-redraw. To do this, uncheck the View | Redraw | Auto Redraw option. The graph will no longer update after every change. To update the graph manually, click the View | Redraw | Redraw command or press F5 on the keyboard.
    3. Turn off symbols. Symbols take a long time to update when the file size is large (or there are many plots with many symbols). Using line plots instead of scatter plots helps the speed. So, for the bulk of editing, try setting the symbol frequency to 0 and the line style to solid. When the graph is finished, you can then set to the symbol frequency to the desired value and the line style back to invisible. To change this:
         a. Click on the line/scatter plot to select it.
         b. Click on the Symbol tab in the Property Manager.
         c. Change the Symbol frequency to 0. All symbols are removed.
         d. Click on the Line tab.
         e. Change the Style to Solid.
         f. When the graph is fully created/edited, change the Symbol frequency back to 1 (or the desired value) and the line Style to the previous value.

    Thanks,

    Sabrina

    0
    Comment actions Permalink

Please sign in to leave a comment.