Welcome to Golden Software Support

Can't open Surfer 12: Unhandled exception error

Comments

3 comments

  • Avatar
    broxtonbird
    Attempting to update the video card driver in my virtual machine apparently worked. I'm not sure why exactly because I was told that my driver was up to date, but then Surfer worked the next time I tried starting it up. Thanks
    0
    Comment actions Permalink
  • Avatar
    Kari Dickenson
    Thanks for letting me know!
    0
    Comment actions Permalink
  • Avatar
    Kari Dickenson

    Hello,

    The second portion of the error about DBGHelp.dll actually means that the crash reporting system wasn't able to complete the log. This is actually OK, because we don't get the log/minidump file anymore for Surfer 12 so it doesn't matter.

    The first portion though, about the Unhandled Exception is a problem. When you get this error when first starting Surfer (as opposed to opening or editing a file), this is almost always caused by a bad video card driver on the computer. However, I'm not sure how that works on Parallels. The bad video card driver on the computer crashes, which cause Surfer to crash. I recommend:

    1) First, please update the video card driver for the computer. Going to the card manufacturer's website and downloading the current driver is generally more effective than having Windows look for a new driver. If you can update the video card driver, then restart Surfer and see if that works. Again, I'm not sure how this works in Parallels.

    2) If that does not work, then we can manually configure Surfer to use a Microsoft video driver from the Operating System instead of the driver for the video card. There is a way in the user interface to change this setting, but because you can't even start Surfer to change it, we can add it manually to the registry. I am not sure if you can edit the registry on Parallels though. The registry setting is named "EnableFBO" and forces Surfer to use the Microsoft driver instead of the video card driver. If "EnableFBO" is missing (which it is by default) or if it is set to 1, then Surfer will try to use the video card on the computer. If the entry is present and set to 0, then Surfer will NOT use the video card driver and will always use the Microsoft software driver. I will give you the instructions for Windows, and hopefully you can get it to work on Parallels. To create this setting and set it to 0, follow these steps:

    1. Click the Windows Start button in the lower left of your desktop
    2. Type in regedit and press ENTER on the keyboard. This will open the Registry Editor. Be very careful when editing the registry.
    3. Navigate to HKEY_CURRENT_USER\Software\Golden Software\Surfer\12\Settings
    4. Click Edit | New | String Value.
    5. For the name, enter: EnableFBO
    6. Double click on it and enter 0 for the Value data. Click OK.
    7. Close the Registry Editor.
    8. Start Surfer. Does that work?

     

    If that works, the problem is indeed the video card driver. The user interface location for this option is Tools | Options, select Rendering from the list on the left and on the right, the option is Enable OpenGL hardware acceleration. If this option is checked, then Surfer uses the video card driver for OpenGL. If this option is not checked, then Surfer uses the older Microsoft driver.

    3) If you can do the above and it still gives you the error, please let me know what video card make/model and driver version you are using. Then please try installing the free Surfer 13 trial from our website (http://www.goldensoftware.com/products/surfer/trial). Does Surfer 13 give the same error when you try to open it? If so, and it asks you to send in the error report, please send in the report so I can see the details of the error.

    Thanks!

    Kari

    kari@goldensoftware.com

    0
    Comment actions Permalink

Please sign in to leave a comment.